Jump to content
pompeusz666

30-bitowy BCM 3AA..Jakie ma możliwości/Opcje

Recommended Posts

Asystet działa. Bardziej chodzi o to, że kiepsko wyłącza światła. Nie sprawdzałem adaptacji (nie wiem czy da się zwiększyć czułość?).

Poza tym i tak póki co BCM jest na półce, bo adapter do modyfikacji (chyba zrobię każda wtyczkę oddzielnie, muszę pociąć to dziś).

Share this post


Link to post
Share on other sites

Tak piszą na którymś z forum że jak przeszli kamery w lusterku na kamerę w szybę to że asystent słabiej działał, ja nie mogę nic powiedzieć za dużo bo nie miałem jakieś takiej możliwości wykorzystać go w 100% u nas na DK88 jak wlacze i nie widzi z daleka latarni to działa dość fajnie ale mógłby z 2-3sek szybciej readowac, ale u tak nie mogę narzekać. 

Share this post


Link to post
Share on other sites

Radek to ma kamera na szybę 3aa, ty Robert masz 3q0 i one szybciej reagują, ale tak jak piszesz przy przejściu z lusterka na kamerę 3aa ludzie narzekali na spóźniona reakcje.

Share this post


Link to post
Share on other sites

No dobra, ale tego nie nazwę spóźniona reakcją tylko czasami brakiem reakcji. Po kliku mrugnięciach długimi już dałem sobie spokój.

Ogólnie, około 20-30 metrów (około sekunda przed minięciem) ale często wcale nie przełącza.

Zobaczę okienko może szyba jest brudna, ale czy kalibracja cokolwiek zmienia w działaniu Light Assist?

Share this post


Link to post
Share on other sites

Kolejny wieczór walki.

Przedzwoniłem całą instalację, poprawiłem kilka punktów które zrobiłem po swojemu ale i tak nadal jest lipa - działa wszystko poza spryskiwaczem szyby przedniej.

Jeśli dobrze patrzę na schemat - T6ap/1 = T52b-2 / T6ap-4 = T52a-43

T6ap/1 i T6ap/4

Niestety oba piny mają stały 12V. Gdzie szukać błędu?

BCM B67.xlsx

Share this post


Link to post
Share on other sites

Chyba jednak błąd jest w połączeniach, bo powinno być tak:

T6ap/1 -> T52b-1 - zasilanie z bezpiecznika SC40 (w B7)
T6ap/2 -> T52a-43 - sygnał "dodatni"
T6ap/4 -> T52b-2 - sygnał "ujemny"

Pompka spryskiwacza jest sterowania w układzie mostka "H" ponieważ w wersji Variant zmienia się polaryzacja zasilania pompki w zależności: przód/tył.

Porównując schematy B6 i B7, widać różnicę w podłączeniu pompki w wersji Sedan. W B6 "+" pompki podłączony jest wprost do bezpiecznika zasilającego, natomiast w B7 jest on podłączony do wyjścia A43. Powód? Prawdopodobnie unifikacja albo dodatkowa diagnostyka pompki, bo jak wiadomo w tej kwestii BCM bywa markotny i nieraz trzeba odłączać aku na kilka chwil, żeby pompka zaczęła działać po jakiejś awarii.

Zrób połączenie jak powyżej i zmień punkt "+" połączenia pompki zgodnie ze schematem od B7. Potem kasowanie błędów, jeśli są oraz twardy reset zasilania i powinno pomóc.

Share this post


Link to post
Share on other sites

To ja się powyżej machnąłem. Schemat jest tak jak napisałeś (w Excelu jest poprawnie). Odłączyłem aku ale to nic nie dało... Na Bordzie działa, tu nie chce.

Share this post


Link to post
Share on other sites

A próbowałeś robić test pompki z VCDS'a? 

Share this post


Link to post
Share on other sites

Teraz wyrzuca błąd.

IMG_20210628_132604.jpg

Edit

@nTomek

Jednak jak zawsze mój błąd - adapter był ok ale nie wpadłem na to, żeby przepinowac wtyczkę T6ap... Przeniosłem pin 4 do pinu 2 (u mnie pusty, bo sedan) i śmiga...

Zostaje tylko błąd komunikacji z ECU ale nie widzę nieprawidłowości w działaniu, więc poczekam.

Dzięki za pomoc!

  • Like 1

Share this post


Link to post
Share on other sites
W dniu 26.02.2019 o 09:57, nTomek napisał:

Z bajtem 18 nie jest tak jak z innymi. Tu nie mają znaczenia poszczególne bity tylko cała wartość. 

Moduł BCM steruje wszystkie światła na podstawie konfiguracji (nie mylić z kodowaniem) zapisanej w wewnętrznej pamięci eeprom pod adresem 0x0C01. Konfiguracja składa się z 47 bajtów. Można ją odczytywać i zapisywać za pomocą VCP. Można też ją edytować za pomocą programu VAGHelper (w VCP też jest edycja, ale uboższa). 

I teraz związek pomiędzy konfiguracją BCM'a a bajtem 18. 

Bajt 18 wyznacza jaką konfigurację ma użyć moduł. Jeśli jest tam 00 to używa tej z pamięci eeprom. Jeśli wpiszemy tam inną wartość to BCM przekopiuje te 47 bajtów z tablicy konfiguracji zapisanej w pamięci ROM (flash) do pamięci eeprom. Tablica zawiera kilkadziesiąt fabrycznych konfiguracji dopasowanych do różnych schematów świateł. 

Reasumując, bajt 18 to nic innego jak tylko numer konkretnej konfiguracji, które są zaszyte w sofcie BCM'a. 

W uzupełnieniu mam coś takiego

Byte 18.pdf

Share this post


Link to post
Share on other sites
23 minuty temu, BRUNO55 napisał:

W uzupełnieniu mam coś takiego

Ta tabela nie pasuje do BCM'a 3AA, który siedzi w Pasacie B7.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Korzystając ze strony akceptujesz nasz Terms of Use oraz Privacy Policy